Kbase P187766: Crystal Reports File DSN connection fails with error 5890 after upgrading to OpenEdge 10.2B03 or lat
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  18/05/2011 |
|
Status: Unverified
SYMPTOM(s):
Crystal Reports File DSN connection fails with error 5890 after upgrading to OpenEdge 10.2B03 or later
Error occurred while accessing component property/method: <property or method name>.
<COM message>
Error code: <Program name> (5890)
Error occurred while accessing component property/method: LogOnServer.
Logon failed.
Error code: 0x80020009 ... (5890)
Application calls Crystal Reports ActiveX Automation objects which uses a File DSN to connect to the OpenEdge database
Application works correctly in versions prior to OpenEdge 10.2B03
Problem does not occur when using a System DSN created from the version 6.00.00.168 ODBC driver instead of a File DSN
Problem does not occur when using a DSN-less connection that references the version 6.00.00.168 ODBC driver
FACT(s) (Environment):
OpenEdge 10.2B02 and lower uses version 5.30.00.109 of the Progress OpenEdge 10.2B Driver
OpenEdge 10.2B03 and later uses version 6.00.00.168 of the Progress OpenEdge 10.2B Driver
Progress OpenEdge 10.2B Driver version 6.00.00.168 becomes the default ODBC driver once 10.2B03 or later is installed
File DSN only saves the name of the ODBC driver used and references information in the registry for additional information (e.g. driver filenames)
OpenEdge 10.2B
Windows
CAUSE:
Bug# DD00059817
CAUSE:
Bug# OE00205286
CAUSE:
New ODBC driver does not handle the full path to the File DSN correctly
FIX:
Option #1
Revert back to Progress OpenEdge 10.2B Driver version 5.30.00.109, making it default.
- Start Regedit.
- Backup the registry.
- For 32-bit Windows, go to:
[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\Progress OpenEdge 10.2B Driver]
- For 64-bit Windows, go to:
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBCINST.INI\Progress OpenEdge 10.2B Driver]
- Change the Driver and Setup entries to point to pgoe1023.dll. For example:
"Driver"="C:\\OPENEDGE_102B\\DLC\\bin\\pgoe1023.dll"
"Setup"="C:\\OPENEDGE_102B\\DLC\\bin\\pgoe1023.dll"
Option #2
Add Progress OpenEdge 10.2B Driver version 5.30.00.109 to the registry as a "new" driver. This will make both version 5.30.00.109 and version 6.00.00.168 available for use.
- Backup the registry using Regedit.
- Create a .REG file and copy/paste the text below (between [Start] and [End]) into it.
- Modify the paths in Driver and Setup to match your installation and save the file.
- Run the .REG file.
- When checking the ODBC Data Source Administrator, entries for both the Progress OpenEdge 10.2B Driver and the Progress OpenEdge 10.2B Driver v5.3 will be present.
- Adjust the File DSN to point to the "new" ODBC driver.
Registry information:
[Start]
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\Progress OpenEdge 10.2B Driver v5.3]
"Driver"="C:\\OPENEDGE_102B\\DLC\\bin\\pgoe1023.dll"
"Setup"="C:\\OPENEDGE_102B\\DLC\\bin\\pgoe1023.dll"
"DriverODBCVer"="3.52"
"APILevel"="1"
"ConnectFunctions"="YYN"
"CPTimeout"="60"
"FileUsage"="0"
"SQLLevel"="0"
"UsageCount"="1"
[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\ODBC Drivers]
"Progress OpenEdge 10.2B Driver v5.3"="Installed"
[End]
Note:
The default .REG file is taken from 32-bit Windows. For 64-bit Windows, the location of the keys must be adjusted to:
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBCINST.INI\Progress OpenEdge 10.2B Driver v5.3]
...
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBCINST.INI\ODBC Drivers]
...
Option #3
Adjust code to use a DSN-less connection. See solution P115877 for more details on how to do this.
Option #4
Create a System DSN for the database using the current (version 6.00.00.168) ODBC driver.
Modify the code to use the new System DSN.