Kbase P187519: Intermittent error 7512 when running sql queries on a batch job from the MS SQL Server linked server
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  5/11/2011 |
|
Status: Unverified
SYMPTOM(s):
Intermittent error 7512 when running sql queries on a batch job from the MS SQL Server linked server against OpenEdge database
=== SQL Exception 1 ===
SQLState=HY000
ErrorCode=-20228
[DataDirect][OpenEdge JDBC Driver][OpenEdge] Access denied (Authorization failed) (7512)
The database log file shows the following error:
SQLSRV2 2: (-----) Authentication service user authentication failure for sysprogress [OpenEdge] - The user failed account authentication
SRV 2: (453) Logout by sysprogress on .
When the batch job is run manually the query runs fine
These errors are apparent after after upgrading from Progress 9.1E to OE10.2B
Upgraded from Progress 9.1E to OE 10.2B using conv910
SYSPROGRESS user account is created via Data Administration on Progress 9.1E database
The same batch job ran without any error when ran against version 9.1E database for many years
No SQL privileges are explicitly assigned to SYSPROGRESS
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge 10.x
Progress 9.x
CHANGE:
Upgraded from 9.1E to OE10.2B
CAUSE:
The problem is unknown at the time of this writing
FIX:
Create a user while logged in as sysprogress and grant either dba to that user or select privileges on all the tables that are being queried from MS SQL Server to that user.