Kbase P187245: WebSpeed agent status stays available despite it is busy running a batch job which causes the WebSpe
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  06/05/2011 |
|
Status: Unverified
SYMPTOM(s):
WebSpeed agent status stays available despite it is busy running a batch job which causes the WebSpeed broker to assign web request to the busy agent as broker is un-ware of the status change
The agent that runs the batch program never change its status from AVAILABLE to BUSY on the broker status query
WebSpeed broker assigns the in-coming web request to busy agent running batch job as a result of AVAILABLE status
Batch program is run through WebSpeed agent by running the program in the run-batch-object procedure
The following environment variables are set to the WebSpeed broker:
STATE_AWARE_ENABLED=NO
BATCH_INTERVAL=15
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge 10.x
CAUSE:
This is an expected behavior. The batch file is expected to run for a very short time at most for a second. Since this is happening under the hood without the acknowledge of the WebSpeed broker, the broker do not know the status of the agent when it runs the batch file.
The following is already written on the web-util.p file as a comment:
/* Batch Interval Time. Amount of time agents sit idle before breaking out of WAIT-FOR and running DB checks and the batch procedure. Wait for web-request for the larger of either 15, or cfg-check-interval seconds. By breaking out of WAIT-FOR we can simulate a batch procedure. NOTE: Anything that goes into the batch program should have a relatively short run time,otherwise agents could potentially all lock. */
FIX:
The workaround is to run a separate WebSpeed broker just to run the batch job, or run a separate batch client using either "-b" option on the ABL client or mbpro script.