Consultor Eletrônico



Kbase P185443: Unable to start AppServer when SYSTEM account does not have access to application folders
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   06/04/2011
Status: Unverified

SYMPTOM(s):

** "" was not found. (293)

Unable to start AppServer Broker

Errors in AppServer Broker log file

IOException reading message from server : java.io.EOFException: pipe to server broken (8117)

Message from server : Startup Procedure Failed (8113)


Exception unbinding broker (not bound) : asbroker1 (8525)

ERROR: cannot start server. (8100)


Errors in AppServer Server log file

** "<file>.p" was not found. (293)

Startup procedure defined for AppServer

FACT(s) (Environment):

Directory where .p file is located is explicitly set in the PROPATH
Starting AdminServer with System Account
Windows
Progress 9.x
OpenEdge 10.x

CAUSE:

The SYSTEM account starting the AdminServer/AppServer does not have any permissions to access the directory where application files reside.

FIX:

Grant SYSTEM account access to the necessary application folders/directories.