Consultor Eletrônico



Kbase P185171: Original installation is not being detected when attempting to install OpenEdge Ultra Control for .N
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   4/6/2011
Status: Unverified

SYMPTOM(s):

Having problems when trying to install OpenEdge Ultra Controls for .Net to an existing installation.

Original installation is not being detected when attempting to install OpenEdge Ultra Control for .Net

The installation of OpenEdge Ultra Controls for .Net requires a development product either previously installed or being installed as part of this installation.

Original installation of OpenEdge Architect is not being detected when running the setup.exe from the original installation directory.

Environment.log file obtained from proinventory shows that there is a registry key missing in [HKEY_CURRENT_USER\Software\PSC\PROGRESS\10.2B\Startup]

FACT(s) (Environment):

Architect is already installed on this machine.
Windows
OpenEdge 10.2x

CAUSE:

Missing Registry entry for [HKEY_CURRENT_USER\Software\PSC\PROGRESS\10.2B\Startup] that indicates where OpenEdge is installed.

FIX:

Run regedit and add a new String Value for the following entry in the registry:

[HKEY_CURRENT_USER\Software\PSC\PROGRESS\10.2B\Startup]

New -> String Value

Value Name:
DLC

Value data:
Path to where OpenEdge is installed. Example:
C:\Progress\OpenEdge

Once this key is added, then run setup.exe again.

The installation should now be able to detect the existence of an OpenEdge installation.