Kbase P184453: Unable to restart AppServers after machine reboot.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  21/03/2011 |
|
Status: Unverified
SYMPTOM(s):
Unable to restart AppServers after machine reboot.
Attempting to start newly defined AppServer encounters no problems.
Systematically copied configuration differences between failing AppServer to newly created AppServer to observe when the new AppServer begins to fail.
AppServer dying when running startup procedure.
AppServer dying when running activate procedure.
AppServer dying when running deactivate procedure.
AppServer Broker logs contains error 8117.
[11/03/18@08:10:55.281-0700] P-003780 T-S-0005 1 UB ---------- IOException reading message from server : java.io.EOFException: pipe to server broken (8117)
FACT(s) (Environment):
All Supported Operating Systems
Progress/OpenEdge Product Family
CAUSE:
Corruption to application code occurred during previous system crash.
FIX:
Copy backups of the compiled r-code or recompile new copies of the r-code and deploy in the correct AppServer application directory.