Consultor Eletrônico



Kbase P184451: Webspeed agents go into a busy state with error 6404 in the Webspeed server log
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   3/21/2011
Status: Unverified

SYMPTOM(s):

Webspeed agents go into a busy state

HTTP ERROR: 500 Internal Server Error

WTA: WebWrite() failed during npp_send with error: size: sentbytes retrycount . (6404)

The server or the system has no more resources. Please contact Progress Technical Support. (748)

FACT(s) (Environment):

Windows
OpenEdge 10.x

CAUSE:

The Webspeed agent is busy due to a coding issue or bad index.
The agent as a result is doing a table scan. Users get impatient
and kill their sessions. The agent can't find the messenger
any more. This results in the error 748. There are
also 10 retries by the agent by default.

FIX:

1. In the OpenEdge installation directory\properties\ubroker.properties file section below change the following from:

[Environment.wsbroker1]
STATE_AWARE_ENABLED=NO
TESTENV=MYENV

to

[Environment.wsbroker1]
STATE_AWARE_ENABLED=NO
AGENT_RETRY_VAL=0

This will change it from 10 retries to just one try, which
will free up the agent faster.

Restart the Webspeed broker.

2. Debug the code using 4GL tracing as per the 4GL tracing solution.
You will be able to see which section of the code is taking too long.
You will see a PID that does not come back in the tracing for a while,
since the agent is busy doing a table scan. It may mean you need to create
a new index and change the code to use it.