Consultor Eletrônico



Kbase P174499: Client process hangs after migrating to OpenEdge on AIX 6.1
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   4/7/2011
Status: Verified

SYMPTOM(s):

Client process hangs after migrating to OpenEdge on AIX 6.1

Unable to clear hanging process even using kill -9

no protrace is generated

When connected via shared memory, resources (including record locks) cannot be released until database is shutdown

When connected via shared memory, records remain locked

Client process may become child of init (parent PID becomes 1)

AppServer processes have been seen stuck in Starting state.

asbman may show agent in Starting state with no PID or port number assigned. These processes never get beyond Starting state.

FACT(s) (Environment):

Client process includes WebSpeed and AppServer agents
Issue happen with both client/server or shared memory connection
When connected via client/server, resources (including record locks) being used by the connection that is hanging can be released by disconnecting via promon
OpenEdge 10.2x
IBM AIX 6.1
OpenEdge 10.1C

CHANGE:

Migrated to IBM AIX 6.1 TL 5 or above

CAUSE:

This is a IBM AIX Bug IZ94396: THERE IS A TIMING ISSUE BETWEEN THE SYNC DAEMON AND A MAPPED FILE.

Applies to AIX 6.1 TL-5 or above.

See https://www-304.ibm.com/support/docview.wss?uid=isg1IZ94396 for more details.


FIX:

Download the Service Pack of 04 TL 06 Fix Central:

http://www-912.ibm.com/eserver/support/fixes/
Upgrade to Service Pack - 'smitty update_all'

(if you have any questions please consult the link below): http://www.ibm.com/developerworks/aix/library/au-aixservicepacks/index.html
After rebooting the server (after upgrading the SP), see if the level is correct and AIX APAR IZ94396 if is installed:

# oslevel -s
# instfix -ik IZ94396

Please consult IBM if you require any clarification on the steps above.