Kbase P183521: Admsrvc.exe and Java.exe are running but proadsv -q indicates that the AdminServer is not running.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  3/4/2011 |
|
Status: Unverified
SYMPTOM(s):
Admsrvc.exe and Java.exe are running but proadsv -q indicates that the AdminServer is not running.
Unable to completely start AdminServer after adding an additional Progress product
10.1b AdminServer under control panel shows as running.
Multiple versions of Progress installed.
On attempt to connect with progress Explorer, 8336 error is reported
AdminServer log indicates a problem with java classes
Classpath in the AdminServerPlugins.properties looks good
Registry looks good.
The 9.1E install looks to have been partially removed.
9.1D install looks complete
Under add remove programs the size of the 10.2B install is over 7GB which is several times normal indicating a possible corrupt install.
FACT(s) (Environment):
Windows Server 2003
Progress 9.1D
Progress 9.1E
OpenEdge 10.1B
CAUSE:
The exact cause is unknown at this time.
FIX:
Follow the following steps to resolve this issue:
1. Truncated the bi of all databases
2. Copy the conmgr.properties file to a directory not effected by the uninstall
3. Make sure there are no Progress processes or Java.exe processes running by checking the Task Manager
4. Uninstall 9.1D normally,
5. Do the same for 10.1B
6. Remove 9.1E manually.
7. Removed any remnants of any of the Progress installs
8. Reboot the box
9. Install Progress 10.1B Client networking and Enterprise database (products used in related case)
10. Test the Progress Explorer (PE)
11. Shutdown the PE and AdminServer
12. Renamed the current conmgr.properties file
13. Copy the old conmgr.properties file back into the properties directory.
14. Restart the AdminServer
15. Test Progress Explorer
16. Check the databases as that is what is managed by Progress Explorer/AdminServer in this instance
17. Test the application