Consultor Eletrônico



Kbase P182507: Getting INVALID RUNTIME LICENSE(1003) error after upgrading from WebSpeed 3.1E to OE10.2B
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   14/02/2011
Status: Unverified

SYMPTOM(s):

Getting INVALID RUNTIME LICENSE(1003) error after upgrading from WebSpeed 3.1E to OE10.2B

The following error is shown in the WebSpeed server log file:

INVALID RUNTIME LICENSE(1003).

The progress message for 1003 error is very different.

Cycle in procedure calls detected in '<procedure>' while executing ASSIGN trigger for <table>.<field>. (1003)

FACT(s) (Environment):

All Supported Operating Systems
WebSpeed 3.x
OpenEdge 10.x

CHANGE:

Upgraded from WebSpeed 3.1E to OE10.2B

CAUSE:

This is a customised error from the WebSpeed application.

FIX:

Need to review ABL code and fix the code to correct the error.

There are at least 3 reasons why it is not a Progress error:
1. The 1003 error on the progress message means:
Cycle in procedure calls detected in '<procedure>' while executing ASSIGN trigger for <table>.<field>. (1003)
2. Progress native error does not capitalize all the letters
3. The period on the error message is before the error number for Progress error not after the error number.