Kbase P181891: Running ABL Application from a desktop icon shows error 354
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  03/02/2011 |
|
Status: Unverified
SYMPTOM(s):
Running ABL Application from a desktop icon shows error 354
Unable to open or create C:\Docume~1\username\local\lbi03144, error 2. (354).
Unable to open or create <filename>, error <number>. (354)
The error 2 on windows means "The system cannot find the file specified".
The -T is set to %TEMP%
The DOS prompt echo show the value of the %TEMP% as C:\Documents and Settings\username\local Settings\Temp
The Windows user environment variable shows the TEMP value as %USERPROFILE%\local Settings\Temp
FACT(s) (Environment):
Windows XP
OpenEdge 10.x
Progress 9.x
CAUSE:
The environment variable on some windows machine causes problem when expanding it if has spaces in the path. In this case when the %TEMP% variable is expanded it only expanded up to C:\Documents and Settings\username\local instead of C:\Documents and Settings\username\local Settings\Temp. This caused the ABL client to not find path to create lbi file; therefore, the error 354 is apparent.
FIX:
There are two options to fix this issue:
First option:
1. Right mouse click on the "My Computer" icon > select properties > Select "Advance" tab > click on the "Environment Variables" button at the bottom
2. Double click on the TEMP user variable under the first section named "User variables for <user name>
3. Place doubles quotes around the variable value so that it looks like the following:
Before Change:
%USERPROFILE%\Local Settings\Temp
After the change:
"%USERPROFILE%\Local Settings\Temp"
4. Save the changes by clicking OK 3 times.
Second option:
On the desktop icon properties, change the -T parameter to the entire long path surrounding double quotes so it looks like the following:
Before change:
-T %TEMP%
After Change:
-T "C:\Documents and Settings\username\local Settings\Temp"