Kbase P178222: Microsoft SQL Server 2005 Linked Server generates error when attempting to view Catalog of a Progres
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  2/3/2011 |
|
Status: Verified
SYMPTOM(s):
Microsoft SQL Server 2005 Linked Server generates error when attempting to view Catalog of a Progress database
Failed to retrieve data for this request. (Microsoft.SqlServer.SmoEnum)
Additional information:
An exception occurred while executing a Transact-SQL statement or batch.
(Microsoft.SqlServer.ConnectionInfo)
The OLE DB provider "SQL Server" for linked server "(null)" reported an error. One or more arguments were reported invalid by the provider.
Cannot obtain the schema rowset "DBSCHEMA_CATALOGS" for OLE DB provider "SQL Server" for linked server "(null)". The provider supports the interface, but returns a failure code when it is used.
(Microsoft SQL Server, Error: 7399)
Microsoft SQL Server 2005 Linked Server is created successfully
No information about the Progress database is available
Problem disappears after applying Service Pack 4 for Microsoft SQL Server 2005
FACT(s) (Environment):
Test Connect with the Progress ODBC driver is successful
Querying the Progress database using the ODBC driver with other utilities (i.e. WinSQL) succeeds; schema and data information can be accessed
Progress 9.1E
OpenEdge 10.0B05 Service Pack
All Supported Operating Systems
MS SQL Server 2005
CAUSE:
Problem appears to relates to a bug in Microsoft SQL Server 2005. Microsoft has similar known issues in this area (http://support.microsoft.com/kb/959031/)
FIX:
Apply Service Pack 4 for Microsoft SQL Server 2005
Contact Microsoft Technical Support for further assistance if the problem persists