Kbase P181198: Database does not register with the AdminServer - errors 8845, 9149, after a system crash.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  1/25/2011 |
|
Status: Unverified
SYMPTOM(s):
Database does not register with the AdminServer - errors 8845, 9149 after a system crash.
Time out limit (<max_wait> seconds) exceeded waiting for ACK. (9149)
Error registering with AdminServer. (8845)
Many databases set to autostart at the AdminServer startup
Correct version of the JDK is installed.
FACT(s) (Environment):
Progress 9.1x
OpenEdge 10.x
All Supported Operating Systems
CAUSE:
The databases are taking an abnormally long time to go through crash recovery because of the previous system crash and are not able to connect to the AdminServer before the max_wait is reached.
FIX:
There are two workarounds for this type of a problem.
1. Manually truncate the bi files after a system crash, to minimize the time it takes the database to go through crash recovery.
2. Adjust the AdminServer startup timing parameters, so the max_wait value is not hit.
Reference solution P14628, "How to tune the AdminServer's database startup timing parameters" .