Kbase P180118: Can not start Webspeed broker error 6396
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  1/11/2011 |
|
Status: Unverified
SYMPTOM(s):
Can not start Webspeed broker
Webspeed broker will not start
Error in Webspeed server log
WTA: npp_enable_connections() failed with error number: -51. (6396)
FACT(s) (Environment):
Windows Vista
OpenEdge 10.2B
CAUSE:
The exact cause is unknown at the time of this writing
FIX:
A workaround is to:
1.Open either Progress Explorer Tool or OpenEdge Explorer
2. Go to the Webspeed folder
3. Choose your Webspeed broker
4. Right click and choose "Properties"
5. Go to Agent>>General
6. In the agent startup parameters, add a -pf <filename.pf>. The .pf file must have a value in it such as -T <path to temp directory>. If you are connecting to the DB, you can just use the database connection parameters or a .pf file with all the DB connection parameter. In other ward, the agent needs a parameter after the -weblogerror on the srvrStartupParam.