Kbase P179893: 4GL Client application is crashing without displaying an error when updating specific records / purc
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  03/01/2011 |
|
Status: Unverified
SYMPTOM(s):
4GL Client application is crashing without displaying an error when updating specific records / purchase orders.
Database log file is showing error 1422 for the client session that terminated abnormally.
SYSTEM ERROR: Index in for recid could not be deleted. (1422)
There are no duplicates associated with the recids listed in the 1422 error.
Issue occurs with multiple purchase orders.
Can access the records or purchase orders using a different index then the one reported in the 1422 error.
FACT(s) (Environment):
Database and client are using Progress version 9.1D09p11
Windows
OpenEdge Category: Database
OpenEdge Database Category: Repair
Progress 9.1D
CAUSE:
Index corruption for specific records.
FIX:
Workaround:
1. Export the records that appear to have index corruption.
2. Run idxfix and select option 6 to delete a record and its indexes.
3. Import the exported records from step 1.
The problem may be related to defects that were addressed in later versions. Recommendation would be to upgrade to a later release of Progress/ OpenEdge where known index corruption issues have been addressed. See solution: P97562, "Error 1422 trying to update a record using Progress 9.1C or later or OpenEdge 10.0x"