Consultor Eletrônico



Kbase P178507: Connecting Crystal Reports using File DSN fails with error 2704
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   20/12/2010
Status: Unverified

SYMPTOM(s):

Connecting Crystal Reports using File DSN fails with error 2704

Logon failed.Details:HY000:[DataDirect][ODBC Progress OpenEdge Wire Protocol driver]Error parsing connect string at offset 198. Attribute specified twice using keywords 'UID' and 'LogonID' [Database Vendor Code: 2704]

Using UID in the file DSN in 10.1C

UID changed to LogonID in the file DSN from 10.1B to 10.1C

FACT(s) (Environment):

Windows
OpenEdge 10.1B
OpenEdge 10.1C
OpenEdge SQL Category: ODBC Drivers

CAUSE:

Progress documents LogonID as the value that gets written to the registry and is accepted on the connection string in 10.1C. UID is no longer used.

FIX:


Change UID to LogonID in the File DSN. In regards to Crystal Reports,
it should work with LogonID. This may require configuration on the Crystal end as well.