Kbase P178527: Errors 1246 and 6142 when connecting from Terminal Server to MS SQL Server through MS SQL Server Dat
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/7/2010 |
|
Status: Unverified
SYMPTOM(s):
Errors 1246 and 6142 when connecting from Terminal Server to MS SQL Server through MS SQL Server DataServer
Cannot access <db-type> with the current License (1246)
Failed to connect to the <db-type> database. (6142)
All but one user gets this error every time the application tries to connect to MS SQL Server
FACT(s) (Environment):
Windows Terminal Services
OpenEdge 10.x
DataServers
CAUSE:
All but this one user's progress.cfg file is pointing to the .cfg file that only has Client Networking license installed. Other users are pointing to the progress.cfg file on the network drive where client Networking and MS SQL Server license is listed.
FIX:
On the user environment under the My Computer > Properties > Advance tab > Environment Variables, add PROCFG variable to point to the correct progress.cfg file.
PROCFG=<path>\progress.cfg
Click OK out the the properties file and re-spawn progress client to connect to the MS SQL Server Database through MS SQL Server DataServer.