Kbase P178328: Database agent fails to register with OE Man Adminserver due to conflicting IP Addresses
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/3/2010 |
|
Status: Unverified
SYMPTOM(s):
Database agent fails to register with OE Management
Java exception in ads0.exp
Message (excp): Exception creating connection to: <ip address>; nested exception is:
java.net.SocketException: Network is unreachable: connect
Stack Trace:
java.rmi.ConnectIOException: Exception creating connection to: 169.254.216.48; nested exception is:
java.net.SocketException: Network is unreachable: connect
at sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEndpoint.java:587)
at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:185)
at sun.rmi.transport.tcp.TCPChannel.newConnection(TCPChannel.java:171)
OpenEdge Management/Explorer shows the database as offline even though it is running.
Database log file shows a different IP address than what is in java exception
Dbagent still connected to the database.
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge Explorer 10.2x
OpenEdge Management 3.1x
OpenEdge 10.2x
CAUSE:
AdminServer is binding to a different IP address due to the existence of Multiple NIC cards.
FIX:
Bind the AdminServer to the IP address used by the database. Use solution P137292 to accomplish this task.