Kbase P175623: Unable to add AppServer agents to running AppServers.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  13/12/2010 |
|
Status: Unverified
SYMPTOM(s):
Unable to add AppServer agents to running AppServers.
The AppServer's broker.log has (8117), (8091), and (8087) errors.
Users already running the application can continue to run, but new users are unable to connect to the database because there are no available AppServer agents.
IOException reading message from server : <IOException_string> (8117)
Error <errMsg> ... disconnecting client. (8091)
Client FSM Error : Invalid ACTION for STATE : state= <state> <descState> event= <event> <descEvent> action= <action> nextState= <state> <descState>. (8087)
Client FSM Error : Invalid ACTION for STATE : state= 0 STATE_IDLE event= 8 EVENT_ERROR action= 10 nextState= 9 STATE_OBLIVION . (8087)
The AppServer's server.log file has (9407) errors.
Connection failure for host <host_name> port <port> transport <transport_name>. (9407)
Querying the AppServer's status in Progress Explorer shows that the number of Active agents continually increases. The number of Busy and Available agents fluctuate in values in each 5 second sample taken.
Increasing the logging level for the NameServer shows requests coming in from many different IP addresses.
Checking running services on a client PC shows that there is a service running that periodically queries the database for print jobs that need to be processed.
FACT(s) (Environment):
The AppServer is running in state-reset operating mode.
Windows
OpenEdge 10.2A
OpenEdge Server Technology Category: AppServer
CHANGE:
Clients have recently been switched from connecting to a Citrix server to start a remote client session to using their local PC's to start a remote client.
CAUSE:
When migrating from the Citrix client server to individual PC's, the print service running on the Citrix server was copied to each of the 300+ local PC's. That is causing 300+ processes to wake up every few minutes and run a query looking for jobs to print. This is exceeding the available number of AppServer agents that the system can handle.
FIX:
Remove the printer service from the local PC's and leave it running only on the Citrix client server, which is still being used by some users.