Kbase P177175: Fathom Trending User terminates with Overflow error (7485)
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/11/2010 |
|
Status: Unverified
SYMPTOM(s):
Fathom Trending User terminates with Overflow error (7485)
An SQL Exception occurred during an insert into the trend database. SQLState: HY000
message: [DataDirect][OpenEdge JDBC Driver][OpenEdge] Overflow error (7485)
vendor: -20052
statement: INSERT INTO PUB
Problem with trend data, see admserv.log on trend machine: (9640)
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge Management 3.1x
CAUSE:
SQL Width for fields in the offending table in the trend database were all to small. Exact cause is unknown at time of writing.
FIX:
Review the data sizes for the query in the log file.
Compare the SQL Width for the fields involved.
Us the DB-TOOL to adjust the SQL Width to the proper size for the fields involved.
ie:
Fix SQL-Width error(s) with the dbtool utility as follows:
1.) dbtool <dir/fathom/db/>fathom
<Select> Options
9. Enable/Disable File Logging
2. SQL Width Scan w/Fix Option
<connect>: (0=single-user 1=self-service >1=#threads)? 1
<table>: (Table number or all)? all
<area>: (Area number or all)? all
<display>: (verbose level 0-3)? 0
The resuting "dbtool.out" should show "***" next to the tables affected. In this particular case it was: [ _File; _Field; PUB.Cf_Status.Status_Status],
and second run of dbtool, with the Options 9 and 1, should then report no errors.
Check the trend database startup parameters. If -SQLStmtCache is not set or is under 300, please adjust, to increase the number of cached prepared statements to take effect the next time the FathomTrendDatabase is started.