Kbase P176329: Workscheduler exceptions during startup of OE Management AdminServer
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  5/25/2011 |
|
Status: Verified
SYMPTOM(s):
Workscheduler exceptions during startup of OE Management AdminServer
Exception at Mon Oct 25 15:01:20 EDT 2010: com.progress.isq.ipqos.WorkScheduleException
Message (throw): Problem trending data
Message (excp): null
Stack Trace:
com.progress.isq.ipqos.WorkScheduleException
at com.progress.isq.ipqos.WorkManager.scheduleWork
Multiple remote containers configured
Java heap size setting is-Xmx1280m
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge 10.2x
OpenEdge 10.1x
OpenEdge Management 3.2x
OpenEdge Management 3.1x
CAUSE:
Work queue is getting filled up on startup due to the number of remote containers coming on line at one time. The default size of the queue is 1000.
FIX:
1. Stop the Adminserver if it is started
2. Set the "fathomTrendQueueSize" property in fathom.init.params to a number greater than 1000 (the default queue size).
This can be set at the end of the fathom.init.params file, after the psc.clean.from.log.dir.after=14 entry:
fathomTrendQueueSize=2000
3. Start the Adminserver.