Consultor Eletrônico



Kbase P175939: Error 11724 when trying to invoke the Progress Debugger in a remote session..
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   22/10/2010
Status: Unverified

SYMPTOM(s):

Getting error 11724 when trying to invoke the Progress Debugger

The Progress 4GL is not enabled for debugging. Run proDebugEnable from within a proenv session on Windows or from a UNIX shell to enable debugging and set the debuggerEnabled property to 1 for any services that you want to debug. (11724)

FACT(s) (Environment):

The client used to start the debugger has a local OpenEdge installation.
The session being debugged is a session started from a remote installation on a mapped drive and is exactly the same version as the local installation.
In both the local installation and the remote installation, prodebugenable has been run successfully.
Windows
OpenEdge 10.x

CAUSE:

The installation from the mapped drive is causing the startup parameters and environment to conflict. For example, environment variables are referencing the local installation but the files used to start the session are referring to the remote installation.

NetSetup should be run in order to install the correct remote client installation files. However because there is already a local identical version of OpenEdge, then NetSetup will not complete.

FIX:

Use the version of OpenEdge that has been correctly installed for debugging purposes.