Kbase P175669: Progress Explorer fails to connect to adminserver on Linux with error 9897
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/23/2010 |
|
Status: Verified
SYMPTOM(s):
<log file entry> User is not authenticated. (9897)
Connecting from Windows box to Linux server
The adminserv.log file includes a "User not authenticated" error.
Using sha-512 encryption.
FACT(s) (Environment):
Linux
OpenEdge 10.x
CAUSE:
Openedge uses MDA encryption, Ubunto Limux uses sha-512 encryption.
FIX:
Change the encryption from SHA-512 to MD5.
To do this in Ubuntu (v9.04 and later) was to edit /etc/pam.d/common-password file.
To do this;
Login as root (or su to root)
Make a backup of /etc/pam.d/common-password file
Edit the /etc/pam.d/common-password file
On the line:
Password [success=1 default=ignore] pam_unix.so obscure sha512
Change to:
Password [success=1 default=ignore] pam_unix.so obscure MD5
Save the file
Use passwd command to change any user passwords including root. This will re-encrypt the passwords stored in /etc/shadow using MD5. (Note users will not be able to login until password is changed using MD5)
Restart the Admin Server
You should now be able to connect to the Ubuntu Admin Server from Windows Progress Explorer.