Kbase P175441: Error Registry function failed (RegQueryInfoKey) when installing OE10.2B 32-bit on Windows 7 64-bit
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/20/2010 |
|
Status: Unverified
SYMPTOM(s):
Error Registry function failed (RegQueryInfoKey) when installing OE10.2B 32-bit on Windows 7 64-bit
Registry function failed (RegQueryInfoKey)
The C:\windows\oesetup.log file shows the installation failed at:
[Installshield]
Version=12.0.0.58851
[Application]
Name=OpenEdge
Version=10.2B
Company=Company Name
[CompletedEvents]
Event1=[DateTime] The Setup Utility has checked the system requirements
[ResponseResult]
ResultCode=-1
ResultDescription=Installation aborted.
FACT(s) (Environment):
Manually removing every entry of OE10.2B and OE10.2Bu from the registry did not resolved the issue
Installation is done by a local user that is a part of the Administration group
The setup.exe was run as Administrator
Windows 7 64-bit
OpenEdge 10.2B 32-bit
CAUSE:
The exact cause is unknown at this time.
FIX:
A workaround for the issue is to assign all the local security policies (Start -> Settings ->Control panel -> Administrative Tools -> Local Security Policy --> User Right Assignment) to the Administrators group with the exception of the items that begin with "Deny" as well as "Add workstations to domain".
Then once again make sure that the registry is clean of all OE10.2B and OE10.2Bu entries (by making use of the regedit utility).
Then reinstall the OpenEdge 10.2B software.