Kbase P173781: Appserver shuts down with error 8046
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  07/10/2010 |
|
Status: Unverified
SYMPTOM(s):
Appserver shuts down with error 8046
accept() on port <portNum> is interrupted: <InterruptedIOException_string> (8046)
accept() on port 3050 is interrupted: java.net.SocketException: Too many open files : Too many open files (8046)
FACT(s) (Environment):
UNIX
Progress 9.x
OpenEdge 10.x
CAUSE:
Attempting to exceed the limit for file descriptors that the process can open.
FIX:
1. Increase nofiles for the user process.
ulimit -n somevalue
2. Restart the AdminServer and brokers to detect new setting.
If still experiencing issues, set ulimit -n somevalue Example: ulimit -n 90000 in the proadsv script prior to the jvmstart command.