Consultor Eletrônico



Kbase P173210: XML LOAD method crashes client session
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/15/2010
Status: Unverified

SYMPTOM(s):

ProdocLoad+108 error processing XML file

Session crashes with access violation proxml.dll

The problem can only be reproduced at the end user site, not at the ISV's Development environment.

The source code line that triggers the problem is:

lOk = xDoc:LOAD ('LONGCHAR', dataline, FALSE).


The stack trace looks like:

=====================================================
PROGRESS stack trace as of Thu Sep 09 15:24:31 2010
=====================================================
Startup parameters:
-pf C:\Programme\ess\openedge\startup.pf,-cpinternal 1252,-cpstream 1252,-cpcoll German-Library,-cpcase Basic,-d dmy,-numsep 46,-numdec 44,-tok 2048,-inp 8192,-s 256,-evtlevel Brief,-nosavepoint,-rereadnolock,(end .pf),-logginglevel 2,-logfile D:\ESS\apache-tomcat-6.0.20\logs\asbroker1.server.log,-ubpid 4160,-Ms 1,-logname asbroker1,-logentrytypes ASPlumbing,DB.Connects,-logthreshold 0,-numlogfiles 3,-ASID 8,-ubpropfile C:\Programme\ess\openedge\properties\ubroker.properties,-ipver IPv4,-pf D:\ESS\appServer\wowi\wowiServer.pf,-db wb4000,-S 3700,-H localhost,(end .pf)

Exception code: C0000005 ACCESS_VIOLATION
Fault address: 02D53FC8 01:00002FC8 C:\Programme\ess\openedge\bin\proxml.dll

Registers:
EAX:00000018
EBX:028CFC50
ECX:028CFC58
EDX:00050001
ESI:00000000
EDI:00435100
CS:EIP:0023:02D53FC8
SS:ESP:002B:0012F370 EBP:0012F3B4
DS:002B ES:002B FS:0053 GS:002B
Flags:00010206

Call Stack:
Address Frame
02D53FC8 00000000 proDocLoad+108


** ABL Stack Trace **

--> xmlDataLineReader xmlDataLineReader (D:\ESS\AppServer\wowi\xmlDataLineReader.r) at line 29
siNavKXML.p (D:\ESS\AppServer\wowi\siNavKXML.r) at line 32

** Persistent procedures/Classes **

Handle File Name
001000 D:\ESS\AppServer\wowi\xmlDataLineReader.r
000000 D:\ESS\appServer\wowi\essAppServerStartUp.r

//=====================================================
PROGRESS stack trace as of Thu Sep 09 15:24:32 2010
//=====================================================
Exception code: C0000005 ACCESS_VIOLATION
Fault address: 02D53FC8 01:00002FC8 C:\Programme\ess\openedge\bin\proxml.dll

Registers:
EAX:00000018
EBX:028CFC50
ECX:028CFC58
EDX:00050001
ESI:00000000
EDI:00435100
CS:EIP:0023:02D53FC8
SS:ESP:002B:00000008 EBP:0012F3B4
DS:002B ES:002B FS:0053 GS:002B
Flags:00010206

Call Stack:
Address Frame
02D53FC8 0012F3B4 proDocLoad+108


FACT(s) (Environment):

Windows
OpenEdge 10.2x

CAUSE:

The exact cause is unknown at the time of this writing, but essentially the OpenEdge installation is corrupt. The versions of the executable files (_proapsv.exe and prowin32.exe) suggest they are 10.2B FCS versions, but the version file in the installation indicates 10.2B01.

FIX:

Uninstall and reinstall the Progress installation.