Kbase P171571: Running any database command against an existing database causes protrace.* files to be generated an
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  24/05/2011 |
|
Status: Verified
SYMPTOM(s):
Running any database command against an existing database causes protrace.* files to be generated and the commands do not complete
** This process terminated with exit code <number>. (8619)
Exception code: C0000005 ACCESS_VIOLATION
Fault address: 00533ECC 01:00132ECC d:\oe102b\bin\_dbutil.exe
FACT(s) (Environment):
OpenEdge 10.2B
Windows 2003 R2
CAUSE:
Unknown at this time.
FIX:
In the event this is reported again, the following this procedure solved the issue on the customer's database: (this is not reproducible otherwise)
Go to Start -> All Programs -> OpenEdge -> Proenv
Create a new temporary directory by doing 'mkdir C:\directory\db2'
Make an OS copy of the database to the new temporary directory by doing
'copy C:\directory\db\. C:\directory\db2'
Then in the folder C:\directory\db2 edit the .st file and do a prostrct repair
Rename the folder db by doing 'ren C:\directory\db C:\directory\BACKUPdb'
Then recreate a new empty db folder by doing 'mkdir C:\directory\db'
And copy back the db to its original location:
'copy C:\directory\db2\. C:\directory\db'
Then in the folder C:\directory\db edit the .st file and do a prostrct repair again
It was then possible again to start the database by doing a 'proserve C:\directory\db\NameOfDatabase' and closing this database down by doing a 'proshut C:\directory\db\NameOfDatabase'