Kbase P171535: Unable to start database after crash:(43) ** Cannot find or open file d:\dcam.d10, errno = 32.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  8/13/2010 |
|
Status: Unverified
SYMPTOM(s):
Unable to start database after crash.
(12699) Database 1st database Options:
(12699) Database 2nd database Options: which repeats many times followed by bkiowrite error
Second database listed above is actually the Schema holder of the DataServer.
APW 13: (9450) bkioWrite:Insufficient disk space during write, fd 476, len 4096, offset 68148, file d:\dcam.d1.
BIW 11: (2520) Stopped.
(453) Logout by SYSTEM on CON:
APW 13: (3645) bkwrite: write to disk failed errno 0.
BROKER 2: (453) Logout by SYSTEM on CON:.
SRV 1: (2520) Stopped.
SRV 3: (2520) Stopped.
FMAGENT14: (453) Logout by DB_Agent on CON:.
BROKER 0: (2249) Begin ABNORMAL shutdown code 2
BROKER 0: (453) Logout by SYSTEM on CON:.
BROKER : (334) Multi-user session end.
Restart of database failed with:BROKER 0: (43) ** Cannot find or open file d:\dcam.d10, errno = 32.
errno =32:The process cannot access the file because it is being used by another process.
Task manager shows many Progress processes still running.
FACT(s) (Environment):
Georgia Software terminal emulator in use (aggressively holds onto terminal connections)
RF controller being used to connect from RF handhelds (aggressively holds on to RF connections)
Progress ODBC DataServer
Windows
OpenEdge 10.2A
CAUSE:
The database crash did not disconnect all processes and when the database tried to open the extent it was still being held open by one of the processes left behind.
FIX:
Reboot the server to clear all the Progress processes that are still connected to the database.