Kbase P171360: Getting error OE Broker fails to start SQL server (8841) when Fathom Management attempts to connect
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  8/13/2010 |
|
Status: Unverified
SYMPTOM(s):
Getting error OE Broker fails to start SQL server (8841) when Fathom Management attempts to connect to Trend Database started by AdminServer.
8841 error listed in admserv.log
Unable to save trend data. Verify Fathom HTTP server is running on jdbc:datadirect:openedge://localhost:2300;databasename=fathom. (Reason: [DataDirect][OpenEdge JDBC Driver]OE Broker fails to start SQL server.
OE Broker fails to start SQL server. (8841)
SQLExplorer can not connect to database started by AdminServer
Copying command from admserv.log and removing commas then using the command to start database allows SQL Explorer to connect to database.
FACT(s) (Environment):
All Supported Operating Systems
Progress 9.x
OpenEdge 10.x
OpenEdge Management
CAUSE:
The AdminServer was started with a different user than the owner of the database.
Example:
Root owns the database files but the account used to start the AdminServer is myrootuser.
FIX:
Have the account which owns the database files start the AdminServer.
Alternatively, make sure the account which starts the AdminServer is a member of the group that is assigned to the database files.