Consultor Eletrônico



Kbase P170906: Users cannot log in to WebSpeed application
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   12/08/2010
Status: Unverified

SYMPTOM(s):

Users cannot log in to WebSpeed application

Users get no response after entering userid and password into a login pop-up browser.

Login pop-up browser disappears after several seconds.

FACT(s) (Environment):

No error message displayed to user.
No unusual errors in WebSpeed broker/server or database logs.
Sun Solaris SPARC 64-bit
OpenEdge 10.1C

CHANGE:

Recently implemented changes to increase login security, including password hashing.

CAUSE:

Hashing the entered password using the SHA1-DIGEST function, comparing the hash to a value stored in a database table, and performing several other password validation operations all made the login process take slightly longer than before. This meant that WebSpeed agents were tied up slightly longer serving each request. Because the maxSrvrInstance property of the WebSpeed broker was set very close to the expected number of concurrent connections, there were not enough free agents to serve new login requests immediately, and requests were timing out before they were served.

FIX:

Increase the maxSrvrInstance property of the WebSpeed broker in the ubroker.properties file, located in $DLC/properties (UNIX) or %DLC%\properties (Windows). The maxSrvrInstance property can also be modified using Progress Explorer: in the WebSpeed broker properties, expand Agent, click on Pool Range, and enter the desired value in the "Maximum agents:" text box.