Consultor Eletrônico



Kbase P170321: Unable to query _keyevt table
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/29/2010
Status: Unverified

SYMPTOM(s):

Unable to query _keyevt table

ABL queries on _keyevt table fail with not found errors

_KeyEvt table is shown with records in dbanalys report

IDXCHECK on _KeyEvt Table fails errors 8788 8797

ERROR - Unable to find a cursor for a table number lookup. (8788)

ERROR - No table with given table name found in the database. (8797)

Could not find file _KeyEvt in database <dbname> (1494)

IDXCHECK error 8783 on _File _Field and _Index for _keyevt

** FIND FIRST/LAST failed for table _File (565)

** _File record not on file (138)

** Field field_keyevtdate does not exist in table _keyevt. (442)

FACT(s) (Environment):

database has been enabled for keyevents
database is a UTF-8 database
OpenEdge 10.1x
OpenEdge 10.2A

CAUSE:

The exact cause is unknown at the time of this writing

FIX:

Upgrade to latest 10.2A or 10.2B versions.


WORKAROUND:

Once KeyEvents have been enabled, run IDXBUILD on _file _field and _index in the Schema Area.

- OR -

REBASELINE the UTF-8 database.
Then when enabling keyevents, ensure that the -cpinternal UTF-8 is specified
$ proutil < dbname > -C enablekeyevents -cpinternal UTF-8

IMPORTANT NOTE: In the latest OpenEdge 10.2A03 and 10.2B01 versions, it is not necessary to specify the -cpinternal UTF-8 when enabling keyevents on a UTF-8 database.