Kbase P170173: Misleading error (709) when connecting to an OpenEdge database
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  20/07/2010 |
|
Status: Unverified
SYMPTOM(s):
Misleading error (709) when connecting to a Progress Database
** -P and -U startup parameters require _User file records. (709)
Only the last AppServer agent fails to connect to the database
The connection failure of a single agent prevents the whole AppServer from starting up
An SQL client is already connected to the database at the time the first AppServer agent is started.
Reducing the number of initial AppServer agents at startup only reduces the number of incidents
FACT(s) (Environment):
All agents connect to the database at startup, using the same user and password
The user and password information used by the agents to connect to the database is properly defined in the _User table
Connection parameters include -U <username> and -P <password>
Progress 9.x
OpenEdge 10.x
All Supported Operating Systems
CAUSE:
The SQL Client is locking the _User table preventing the database engine from authenticating the connecting AppServer to the database.
FIX:
Review the design of your SQL queries to prevent any locking on the _User table. As an alternative solution, connect the SQL client after all AppServer agents have started up