Kbase P131932: Random Error 8230 when calling procedure from .NET Open Client
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/22/2010 |
|
Status: Unverified
SYMPTOM(s):
Random Error 8230 when calling procedure from .NET Open Client
Connect Failure: NameServer Communications Failure - <Java Exception> (8230)
EXCEPTION: Connect Failure: NameServer Communications Failure - System.Net.Sockets.SocketException: A blocking operation was interrupted by a call to WSACancelBlockingCall
at Progress.SupportClass.UdpClientSupport.Receive(UdpClientSupport tempClient, PacketSupport packet)
at Progress.NameServer.Client.NameServerClient.receiveResponse(Int32 responseCount, String applicationService) (8230)
Using session-free AppServer
Problem can also be reproduced from a ABL client:
Name server at Host 192.168.141.17 Port 5162 is not responding. (8239)
Application Service ErgomedOnline not found at NameServer at Host 192.168.141.17 Port 5162. (8245)
The error messages below appear in the AppServer broker logfile:
IOException received on client connection C-0006 : Connection reset. (8085)
FACT(s) (Environment):
Windows 2003 Standard Edition
OpenEdge 10.1B
CAUSE:
The antivirus software blocks randomly the UDP calls.
FIX:
.NET Open Client uses UDP ports to find a NameServer to talk to. There is no way to specify what specific UDP port will be used for a UDP broadcast message so it is possible that the communication attempt will be blocked. To resolve this, modify the .NET application code and set the Progress.SESSION.NsClientPortRetry property to the number of retry attempts you want to attempt before an exception is thrown (the default is no retry attempts). You can also set the Progress.SESSION.NsClientPortRetryInterval property to how many milliseconds you want to wait before attempting the next connection.