Kbase P168912: ODBC drivers are not working after a Netsetup install and the registry was updated properly
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  7/7/2010 |
|
Status: Unverified
SYMPTOM(s):
ODBC drivers are not working after a NetSetup install
ODBC drivers are not seen within the registry due to known issue with 10.1B
Cannot register the pgoe1022.dll file manually
FACT(s) (Environment):
Updated the registry with the correct driver information per solution P123607
Mapped drive was used as a part of the NetSetup installation.
Installation on server / source machine was a complete installation.
pgoe1022.dll file exists on the source machine where installation was performed.
NetSetup installation occurred without any errors.
Client machine needs to have remote 4GL connectivity to the database which requires the Client Networking product.
Windows XP
OpenEdge 10.1B
CAUSE:
Removed mapped drive to source machine where the NetSetup is sharing the OpenEdge installation.
FIX:
A NetSetup installation is sharing an installation from a source machine. The reference to the source machine needs to be maintained after the NetSetup installation. When the ODBC drivers are registered on the machine where the NetSetup was performed, there will be a reference to the source machine where the drivers actually exist.
If you do not want to reference the source machine, and you require remote 4GL as well as SQL92 connectivity to databases, then you will need to perform a local installation of the Client Networking product. If you have questions or concerns regarding your license compliance, please follow up with your Sales Administrator or Sales Representative.