Consultor Eletrônico



Kbase P167818: Database users hang waiting on BKSH
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   6/11/2010
Status: Unverified

SYMPTOM(s):

Database users hang waiting on BKSH

Running a query on a database table freezes

Promon User Control screen shows that users are waiting on BKSH for a particular dbkey

Promon -> R&D -> debghb -> 6. Hidden menu -> Buffer Locks screen shows a user holding the dbkey that was listed in the User Control screen

FACT(s) (Environment):

UNIX
OpenEdge 10.x

CAUSE:

A Progress user session has disconnected from it's interface (such as a user losing their telnet session), but the process remains in a state whereby it's holding a buffer locked. Other users that try to read information from this same database buffer need to wait for it to be released.

FIX:

Disconnect the user session that is holding the buffer locked.

1. First try disconnecting the user using proshut. It's possible that the user process may shutdown gracefully and release the locked buffer.

2. If disconnecting the user doesn't work then you will need to terminate the Progress client process by sending it a kill signal or by shutting down and restarting the database.

Note that terminating a process that is holding a buffer locked will likely cause the database to perform an abnormal shutdown, so it would be best to schedule a database shutdown and restart to resolve this issue.