Consultor Eletrônico



Kbase P167591: Client connection to 10.2B Database is disconnected when querying _file error 706
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   03/01/2011
Status: Verified

SYMPTOM(s):

SYSTEM ERROR: Could not get _file-num from _file row - retcode: -2 rowid: 11902 (15180)

The error is generated executing the FOR EACH block:

FOR EACH _file NO-LOCK,
EACH _field NO-LOCK OF _file:
END.

The error is also generated executing the FOR EACH block:

FOR EACH _file NO-LOCK,
EACH _field NO-LOCK WHERE _field._file-recid = RECID(_file):
END.

Client connection to 10.2B Database is disconnected when querying _file error 706

(15180) SYSTEM ERROR: Could not get _file-num from _file row - retcode: -2 rowid: 11902


_file query run by an earlier client to an OE10.2B database fails

_file query fails with error 706 and 15180

Error: ** Disconnected by the server, code 49. (706)

Future connections fail with error 12537

Error unlocking after schema read (12537)

Existing clients connected to the remote server remain until the remote server is disconnected

Remote server is eventually cleared by the database manager

Disconnecting client 12 of dead server 1. (2526)

Disconnecting dead server 1. (2525)

proshut hangs if shutdown is executed before the dead server is cleaned up.

The database is still active. Database shutdown is continuing.

The error is generated executing the FOR EACH block:

FOR EACH _file WHERE _file._file-number > 0
AND _file._file-number < 30000 NO-LOCK BY _file-nam:
END.

FACT(s) (Environment):

The problem only manifests when the database is upgraded to OE 10.2B
Client is any pre 10.2B client eg 10.2A, 10.1C, 10.1B

No problem identified with any other code running with the 'earlier' major client version except queries on _file
No problems identified with running this _file query between any of the earlier major 10.1B, 10.1C, 10.2A database versions
All Supported Operating Systems
OpenEdge 10.2B
OpenEdge Category: Database

CAUSE:


Bug# OE00198096

CAUSE:

This is a known issue which is limited to metaschema tables. There were significant changes in OpenEdge 10.2B for Transparent Database Encryption and the Secondary Buffer Pool.

FIX:

Option #1
Upgrade to 10.2B02

Option #2
When running database metaschema queries against an OpenEdge 10.2B database, ensure that the client is the same version as the database