Consultor Eletrônico



Kbase P167205: After a couple of minutes the OpenEdge Web Service can no longer be accessed
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   6/1/2010
Status: Unverified

SYMPTOM(s):

After a couple of minutes the OpenEdge Web Service can no longer be accessed

Errors (10893), (11506) and (10899) when making a Web Service request after some inactivity

Web service operation <operation-name> generated a SOAP Fault. SOAP faultstring is: An error was detected while executing the Web Service request. (10893) (11506)

An error was detected while executing the Web Service request. (10893)

Web service operation <operation-name> generated a SOAP Fault. SOAP faultstring is: <fault-string> (11506)

A network error occurred executing the Web Service application. (10899)

There is a firewall between the WSA and the AppServer

The WSDL document is still accessible through the WSA

The SOAP fault is generated only for the first Web Service request after the inactivity

Subsequent requests to the Web Service work just fine

This only occurs with the Session Free Model of Web Service

The AppServer Broker used by the Web Service has an Operating Mode of State-free

The following JAVA Exceptions appear in the WSA log file

com.progress.ubroker.client.BrokerSystem$BrokerSystemCommunicationsException: Client Communications Failure - java.net.SocketException: Software caused connection abort: recv failed (8409)

Client Communications Failure - <Java Exception> (8409)

DISCONNECT IOException: java.net.SocketException: Software caused connection abort: socket write error

com.progress.open4gl.Open4GLException: Disconnect failure: NULL.

Error in SOAP request execution: Communication layer message: Client Communications Failure - java.net.SocketException: Software caused connection abort: recv failed (8409). (7175) (10926)

Error in SOAP request execution: Communication layer message: Client Communications Failure - java.io.EOFException (8409). (7175) (10926)

FACT(s) (Environment):

OpenEdge 10.x
All Supported Operating Systems

CAUSE:

Some firewalls are configured to close network connections that remain idle for a specified amount of time. Such a timeout period might cause an idle AppServer connection to be dropped.

FIX:

Use one of the following suggestions to prevent the error:
- Disable or increase the firewall timeout.
- Generate network activity to the AppServer.
- Lower the TCP/IP KeepAlive value for your OS to be lower than firewall timeout.