Kbase P166731: Batch job ran from the Windows Task Scheduler is unable to connect to an AppServer
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  27/05/2010 |
|
Status: Unverified
SYMPTOM(s):
Batch job ran from the Windows Task Scheduler is unable to connect to an AppServer
Batch job attempts to connect to an AppServer
FACT(s) (Environment):
The same batch job, when executed from the command line works fine.
Person executing the job via the scheduler is the same person that is running the batch job from command line.
The batch job when ran from the scheduler does get executed.
The batch job when executed from the scheduler can initiate an _progres client.
Windows Server 2008
Windows
OpenEdge 10.1B
CAUSE:
The client is coded to look at HKEY_CURRENT_USER for some registry keys. If these keys do not exist, then the client looks in HKEY_LOCAL_MACHINE for some default keys. The default keys in this case had an old obsolete IP address. This obsolete IP address prevented the client from connecting to an AppServer as the IP was incorrect.
FIX:
Modify the default keys in HKEY_LOCAL_MACHINE to contain the correct IP address being used in the connection string for the client when connecting to an AppServer.