Consultor Eletrônico



Kbase P166094: Software Updates menu doesn't start in Architect Help menu.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   5/14/2010
Status: Unverified

SYMPTOM(s):

Software Updates menu doesn't start in Architect Help menu.

Software Updates menu doesn't start

Installed SourceGear vault plugin.

FACT(s) (Environment):

No errors to screen
Windows
OpenEdge 10.2B

CAUSE:


The problem is the syntax in the config.ini file located in the eclipse\configuration folder.
The line:
eclipse.p2.data.area=/C\:\\PROGRESS\\OE102B\\oeide\\eclipse\\p2\\

was changed to:
eclipse.p2.data.area=@config.dir/C\:\\PROGRESS\\OE102B\\oeide\\eclipse\\p2\\

causing Software Updates to fail.
By default, when you open Architect for the first time this property will be set to the value

eclipse.p2.data.area=@config.dir/../p2/

config.dir will be the ${ECLIPSE_ROOT}/configuration directory. This entry was overwritten after installing the SourceGear vault plugin.

FIX:


1.In the config.ini file, remove the @config.dir in the line:
eclipse.p2.data.area=@config.dir/C\:\\PROGRESS\\OE102B\\oeide\\eclipse\\p2\\

2. Restart Architect.

Once that is done, you can also use the line:
eclipse.p2.data.area=@config.dir/../p2

Instead of:
eclipse.p2.data.area= /C\:\\PROGRESS\\OE102B\\oeide\\eclipse\\p2\\