Kbase P165808: Getting errors when executing prokb.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  5/12/2010 |
|
Status: Unverified
SYMPTOM(s):
Getting errors when executing prokb.
msgOpen: unable to open message file: PROMSGS
Made a shortcut of the _prokb.exe from the PROKB installation directory.
FACT(s) (Environment):
PROKB works correctly when started from Start -> Programs -> Progress PROKB -> Progress PROKB menu option.
Right click -> Properties on the Progress PROKB menu option has a Target line of: C:\ProKB\_prokb.exe -ininame Prokb.ini -db db\prokb -1 -RO -p rcode\_prokb.r -T tmp
Downloaded the prokb tool from Progress website according to link in solution: P101115
Windows
Progress/OpenEdge Product Family
CHANGE:
Upgraded from Windows XP to Windows 7.
CAUSE:
A shortcut created from the PROKB installation directory will have a Target line of:
Target: C:\ProKB\_prokb.exe. This is an incomplete target line meaning that it will only point to the _prokb.exe executable itself. The _prokb.exe needs to have several startup parameters passed to it which inform the executable about it's environment and where the source code is that the executable will invoke.
FIX:
1. Either use the Progress PROKB menu option located via Start -> Programs -> Progress PROKB. or
2. Modify the Target line for your shortcut:
From: C:\ProKB\_prokb.exe
To: C:\ProKB\_prokb.exe -ininame Prokb.ini -db db\prokb -1 -RO -p rcode\_prokb.r -T tmp