Consultor Eletrônico



Kbase P165511: Probkup online continually reduces the number of available remote user connection slots, causing err
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   21/04/2011
Status: Verified

SYMPTOM(s):

Remote 4GL and SQL clients can't connect to a database.

Remote 4GL clients are getting 748 errors.

The server or the system has no more resources. Please contact Progress Technical Support. (748)

SQL connection fails with error Broker rejects connection.

Broker rejects connection

SQL Error State:S1000, Native Error Code:FFFFBoFF, ODBC Error: [DataDirect][ODBC Progress OpenEdge Wire Protocol driver][OPENEDGE]Broker rejects connection.

Remote clients were able to connect to the database earlier, but after a period of time no longer can connect to the database.

Probkup online continually reduces the number of available remote user connection slots, causing error 748 on remote clients.

The total number of remote users that can connect to the database reduces with each subsequent online probkup.

FACT(s) (Environment):

Backups run at regular intervals with probkup online command.
Remote server processes have sufficient slots available to handle additional connections according to promon.
promon -> R&D -> Status -> Servers shows that there are Remote Server slots available to accept remote client connections.
Client Server database startup parameters are configured correctly for the number of clients attempting to connect to the database.
Self Service clients are able to connect when Client Server connections cannot
All Supported Operating Systems
OpenEdge 10.2B
OpenEdge Category: Database

CAUSE:

Bug# OE00197492

CAUSE:

In OpenEdge 10.2B, online probkup is being counted as part of the usrcnt for the database. The value is incremented every time a probkup process is being initiated. However, the value is never being decremented once the probkup online completes successfully. Over time, this exhausts the number of slots available for remote users being allowed to connect to the database which results in 4GL client side 748 error messages. This defect will not cause problems in releases of OpenEdge prior to 10.2B as the original code change that caused this problem is specific to encryption which is a new feature specific to the OE 10.2B release.

The issue will not be exhibited until a number of online backups ave been run. It depends on how many users are configured for the database (-n parameter); how many online probkup commands are performed and how often the database is restarted, but the database can eventually get into a state where client server connections are no longer able to connect to the database.

If you view the database license file (dbname.lic) in an editor you will see license counts that are greater than the -n setting including the self service connections and/or auxiliary processes such as an APW. This can be seen in the VSTs as well.

FIX:

Fixed in 10.2B02 or higher.

Workarounds:

1. Reduce the number of online probkup commands scheduled to run between database re-starts.
2. Increase the database startup parameter: Maximum Number of Users (-n) by 1 for every online probkup that is scheduled to run prior to the next database restart.
3. Increase the frequency of database shutdown and restart to reinitialize the counters.