Consultor Eletrônico



Kbase P162523: Remote clients are getting disconnected from the database randomly.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   28/10/2010
Status: Verified

SYMPTOM(s):

Remote clients are getting disconnected from the database randomly.

This started only after migrating to OpenEdge 10.

Customers never experienced this problem running Progress version 9.

Database log file has abnormal termination errors.

Usernum terminated abnormally. (794)

Database log file shows TCP/IP errors directly following the abnormal termination errors.

SRV 10: (-----) TCP/IP write error occurred with errno 32

protrace files that are created as a result of the clients terminating abnormally all point to one of three different application programs at a particular line within that program.

A compile listing of those application programs sited in the protrace files show that the error occurs when trying to run a "CREATE FILL-IN"

Stack trace from prowin32.exe reads:
The following, prowin3215224.dmp matches the time of protrace.3812 exactly:
WARNING: Stack unwind information not available. Following frames may be wrong.
kernel32!RaiseException+0x3c
msvcr71!_CxxThrowException+0x34
xerces_c_2_1_0!XMLScanner::scanReset+0x1c4
xerces_c_2_1_0!XMLScanner::scanDocument+0x28
xerces_c_2_1_0!XMLScanner::scanDocument+0xc6


FACT(s) (Environment):

Windows Server 2003
OpenEdge 10.1B03 Service Pack
OpenEdge 10.2A 32-bit
OpenEdge 10.2B

CAUSE:

Bug# OE00197038

CAUSE:

A client session may crash when creating a fill-in field if the session codepage is a multi-byte codepage like utf-8.

FIX:

Upgrade to OpenEdge 10.2B02 or later