Consultor Eletrônico



Kbase P160813: Application fails during client login with the error "prowin32 has stopped working".
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   4/1/2010
Status: Unverified

SYMPTOM(s):

The application fails during client login with the error "prowin32 has stopped working".

The login fails with the above error periodically. If the login fails and the user attempts logging in again, they will succeed after anywhere from two to six tries.

The Windows Application Event Log does have Application Error listed at the time the client login failed.

Log Name: Application
Source: Application Error
Date: 2/25/2010 10:28:33 AM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: PROD-BB-RDS1.ace.corp
Description:
Faulting application name: prowin32.exe, version: 10.1.3.1526, time stamp: 0x4a207428
Faulting module name: pngfilt.dll, version: 8.0.7600.16385, time stamp: 0x4a5bdaee
Exception code: 0xc0000005
Fault offset: 0x00001bbb
Faulting process id: 0x2428
Faulting application start time: 0x01cab62f26639f86
Faulting application path: C:\psc\bin\prowin32.exe
Faulting module path: C:\Windows\SysWOW64\pngfilt.dll

FACT(s) (Environment):

Windows Server 2008
OpenEdge 10.1C03 Service Pack

CAUSE:

The Windows Data Execution Prevention (DEP) settings are set to "Turn on DEP for all programs and services except those I select:". None of the Progress executables are listed in the exceptions.

FIX:

Either add the Progress executables (in this particular case prowin32.exe) to the list of DEP exceptions, or select the other DEP setting of "Turn on DEP for essential Windows programs and services only".
Applications that attempt to violate Data Execution Prevention checks will throw a STATUS_ACCESS_VIOLATION (0xc0000005) exception.