Consultor Eletrônico



Kbase 18689: ODBC Problems from 9.0A to 9.0B
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   25/04/2006
Status: Unverified

FACT(s) (Environment):

Progress 9.0B

SYMPTOM(s):

Problems running via ODBC

CHANGE:

Upgrade from Progress 9.0A

CAUSE:

1) 9.0B when installed notices that there is already a Progress ODBC driver installed and does not install the new drivers that comes with 9.0B.

2) Uninstalling 9.0A does not remove the old ODBC driver properly nor does using the Control Panel - Add/remove programs icon to remove "PROGRESS ODBC".

FIX:

Check for 9.0A on the offending machine. Go into Control Panel - ODBC Data Sources Icon and click on the "Drivers" tab. If you do not see a driver with the name INTERSOLV 3.11 32-BIT PROGRESS listed, then it did not install the new drivers.

To get this to work, uninstall 9.0B, run the Control Panel - Add/remove programs icon to remove "PROGRESS ODBC". The following registry keys will need to be deleted manually:

HKEY_LOCAL_MACHINE - SOFTWARE - ODBC - ODBC Drivers -
Progress ODBC driver

HKEY_LOCAL_MACHINE - SOFTWARE - ODBC - ODBCINST.INI -
Progress ODBC Driver

Once that is done, reboot the machine and reinstall 9.0B.