Kbase P161955: Cannot connect with JDBC error com.db.ddtek.jdbc.openedge.opedgedriver
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  3/16/2010 |
|
Status: Unverified
SYMPTOM(s):
Cannot connect with JDBC
com.db.ddtek.jdbc.openedge.opedgedriver
Error 785 in database log file when broker was starting
The port <n> is already in use. (785)
FACT(s) (Environment):
Connecting in OpenEdge Architect
No errors in database log file at time of connection
Windows
OpenEdge 10.2x
CAUSE:
The secondary broker never started.
FIX:
1. Stop the main broker.
2. Restart the main and secondary brokers.
3. If the secondary broker still will not start determine what is
using the port using OS utilities such as netstat. Otherwise
change the port that the secondary broker uses and
change the client connection string to use the new port.