Consultor Eletrônico



Kbase P161949: proadsv -start fails with java.lang.NullPointerException error
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   8/16/2010
Status: Verified

SYMPTOM(s):

proadsv -start fails with java.lang.NullPointerException error

Exception written to admserv.log file:

OpenEdge Release 10.2B as of Mon Dec 14 19:15:32 EST 2009
Exception in thread "main" java.lang.NullPointerException
at com.progress.common.util.acctAuthenticate.add37(acctAuthenticate.java:503)
at com.progress.common.util.acctAuthenticate.add37(acctAuthenticate.java:539)
at com.progress.common.util.acctAuthenticate.getValue(acctAuthenticate.java:629)
at com.progress.common.util.acctAuthenticate.generatePassword(acctAuthenticate.java:637)
at com.progress.common.util.acctAuthenticate.clientGeneratePassword(acctAuthenticate.java:893)
at com.progress.common.util.acctAuthenticate.generatePassword(acctAuthenticate.java:292)
at com.progress.chimera.adminserver.AdminServerType.main(AdminServerType.java:1042)

hostname command is returning with -s value.

FACT(s) (Environment):

uname -a returns the correct hostname.
ping IP address and it resolves to the correct one as validated in /etc/hosts file
HP-UX 11i v3
ia64 (Itanium)
OpenEdge 10.2B

CAUSE:

Hostname is not set correctly on this machine.

FIX:

Fix hostname on machine so that hostname call resolves to the appropriate hostname that is configured for this machine.