Kbase P130848: Progress Explorer to an AdminServer on HP-UX causes the AdminServer to crash.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/03/2010 |
|
Status: Unverified
SYMPTOM(s):
A Connection attempted with Progress Explorer to an AdminServer on HP-UX fails with error 8336.
Unable to connect to Admin Server. Ensure Admin Server is running. (8336)
Failed connection by Progress Explorer crashes the AdminServer.
AdminServer default port, 20931, goes from LISTENING to FIN_WAIT_2.
Error. Unmarshalling return header.
Connection failed. Server is not available. (7447)
nsman -query -host HPmachinehostname -User -password also results in the AdminServer crashing.
Output from setting PSC_DEBUG_AUTH prior to starting the AdminServer and then querying it outputs the following information to the authdbg.log:
IN whoami
whoami returns: root
IN validate_account root xxxxxx NULL
IN testUserPasswordForNull root xxxxxx
IN validatePassword root xxxxxx NULL
IN isGeneratedPassword = xxxxxxxx
IN authorizeUser root NULL NULL
Return status of authorizeUser = 1
Return status of validate_account = 1
IN validate_account root xxxxxx NULL
IN testUserPasswordForNull root xxxxxx
IN validatePassword root xxxxxx NULL
IN isGeneratedPassword = xxxxxxxx
IN authorizeUser root NULL NULL
Return status of authorizeUser = 1
Return status of validate_account = 1
IN validate_account root xxxxxx NULL
IN testUserPasswordForNull root xxxxxx
IN validatePassword root xxxxxx NULL
IN isGeneratedPassword = xxxxxxxx
IN validateUserPassword root xxxxxx
Calling getpwnam()
Calling getspnam()
FACT(s) (Environment):
nsman -query on the same machine works fine.
The Operating System makes use of a shadow password file.
proadsv -query command shows AdminServer is alive prior to the connection
proadsv -query command after a user queries the remote AdminServer shows that the server is no longer running
NameServer process will continue to run unmanaged as the AdminServer that initiated it has crashed.
Client machine where Progress Explorer is running is Windows XP SP2 with 10.1B03
Issue occurs when using any user including root.
HP-UX
HP-UX 11i Itanium
HP-UX 11i 64-bit
OpenEdge 10.1B
OpenEdge 10.1B03 Service Pack
CAUSE:
Bug# OE00170545
CAUSE:
The auth.dll supplied with OpenEdge was missing the link to the system library associated with the getspnam () call.
FIX:
Upgrade to 10.1C02 or 10.2A or later.