Kbase P155991: Cannot restore a database using version 10.2A that was backed up in version 10.1A
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  01/03/2010 |
|
Status: Unverified
SYMPTOM(s):
Cannot restore a database using version 10.2A that was backed up in version 10.1A
CRC check error reading backup block 1 (1147)
Database was backed up using 10.1A0228
Database is being validated with OpenEdge 10.2A or later
FACT(s) (Environment):
Backing up and restoring to disk
Restore using version 10.1A works
Database scan is clean
No disk errors
Works for 7 other databases using 10.2A
IBM AIX
OpenEdge 10.1A
OpenEdge 10.2A
OpenEdge Category: Database
CAUSE:
Verification or restore of a database that was backed up with one version of OpenEdge is not expected to work when used against a backup file that was created from a different version of OpenEdge. Example: Backing up database in 10.1A and then attempting to verify or restore the database with 10.2A. Backing up and restoring across versions of OpenEdge are not expected to work. There are times when these actions do work, however they are not certified or tested as the function is unsupported.
FIX:
The version of OpenEdge being used to restore a database needs to be the same as the version of OpenEdge used to take the backup.
For more Important Rules for restoring backups, please see The OpenEdge Data Management: Database Administration Guide in the section titled Restoring a database.