Consultor Eletrônico



Kbase P153084: Unable to start WebSpeed servers on Windows
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   04/03/2010
Status: Unverified

SYMPTOM(s):

Unable to start WebSpeed servers

S-0001>(Sep 22, 2009 14:03:29:465) Timeout while listening for server : java.io.InterruptedIOException: Accept timed out
S-0001>(Sep 22, 2009 14:03:29:465) ERROR: cannot start server. (8100)
L-7001>admin error response received: 2. (8067)

WebSpeed section in ubroker.properties file shows that WebSpeed is trying to access remote
etwork resources

Parameter File (.PF) used by WebSpeed is located on a shared (network) drive

Procedure Libraries (.PL) used by WebSpeed is located on a shared (network) drive

WebSpeed's PROPATH contains directory entries located on a network drive

FACT(s) (Environment):

Windows XP
Progress 9.x
OpenEdge 10.x
WebSpeed 3.x

CAUSE:

Local System Account used to start the Adminserver. The WebSpeed server process (ie. %DLC%\bin\_progres.exe) will inherit the permissions from Local System Account. By default Local System Account has no access to network resources (shares).

FIX:

Allow the Local System Account to access shared network drives (which could pose a security risk) or copy/move all resources WebSpeed needs to access (eg. .R code, Parameter Files, Procedure Libraries etc.) to a local drive.