Kbase P160159: Nightly backup process used to proquiet 4 databases, split mirrors and then disables proquiet appear
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/02/2010 |
|
Status: Unverified
SYMPTOM(s):
Nightly backup process used to proquiet 4 databases, split mirrors and then disables proquiet appears to have hung / stalled.
Database log files do not show that the batch process even attempted to disable proquiet against the databases.
proquiet command had to be manually entered in order to disable quiet point against all databases.
[2010/02/12@06:52:31.795-0500] P-144082 T-1 I DBUTIL169: (5569) Quiet point request login by vista on /dev/pts/3.
[2010/02/12@06:52:31.998-0500] P-160352 T-1 I BROKER 0: (5584) Quiet point has been disabled by the broker.
[2010/02/12@06:52:32.803-0500] P-144082 T-1 I DBUTIL169: (453) Logout by vista on /dev/pts/3.
FACT(s) (Environment):
Batch process is a script that proquiets multiple databases.
BCV technology then splits mirrors and copies data to tape.
Batch process then disables the proquiet command against multiple databases.
Database log files do not show any errors indicating problems with the database.
The proquiet was successfully enabled by the batch job against all 4 databases.
[2010/02/12@06:25:32.484-0500] P-708710 T-1 I DBUTIL 88: (5569) Quiet point request login by vista on batch.
[2010/02/12@06:25:32.552-0500] P-160352 T-1 I BROKER 0: (5583) Quiet point has been enabled by the broker.
OpenEdge 10.1C03 Service Pack
PowerPC 64-bit
CAUSE:
The issue is not a Progress / OpenEdge issue. Something not associated with the databases resulted in the 3rd party backup mechanism stalling. We know this because the proquiet command was successfully enabled. After enabling the quie tpoint, the script should have split the mirrors and then backed up the data and then issued a proquiet disable. The fact that the database log files show that the proquiet disable was not enabled by batch is indicative that something with the 3rd party backup routine failed or experienced errors.
FIX:
Review and address any errors or failures that may have occurred associated with 3rd party backup process.